Destination Delivery Delays

Incident Report for AppOmni

Resolved

Destination delivery is caught up for all impacted customers.
Posted Sep 16, 2026 - 17:27 EDT

Monitoring

A fix has been implemented and the destination delivery backlog is draining. We will continue to monitor until delivery delays have fully caught up.
Posted Sep 16, 2026 - 14:47 EDT

Identified

We have identified the issue and are working on a fix.
Posted Sep 16, 2026 - 13:43 EDT

Investigating

We are investigating an issue with delayed delivery to destinations for some US-based customers.
Posted Sep 16, 2026 - 11:59 EDT
This incident affected: Threat Detection.