Degradation of AppOmni Console Performance

Incident Report for AppOmni

Resolved

The degradation of performance for US-based customers has been resolved. We will continue to actively monitor performance to ensure there are no regressions.
Posted Mar 13, 2026 - 10:19 EDT

Investigating

We are experiencing degradation of performance for US customers attempting to access the AppOmni console. We are currently investigating the issue.
Posted Mar 13, 2026 - 09:05 EDT
This incident affected: AppOmni Console.