Google Cloud Outage Impacting Services

Incident Report for AppOmni

Resolved

Google Cloud services have been fully recovered and this incident has been resolved.
Posted 1 month ago. Jun 12, 2025 - 21:03 EDT

Update

Most of the Google Cloud products have confirmed full service recovery.

There are still a few Google Cloud services experiencing some residual impact, but they are expected to complete recovery in less than an hour.

We are continuing to actively monitor the situation and will restore full functionality as soon as the underlying problems are fully resolved.
Posted 1 month ago. Jun 12, 2025 - 17:42 EDT

Monitoring

We are currently experiencing service degradation due to a widespread Cloud outage affecting multiple core services. Our systems may be impacted as a result of these upstream issues.

We are actively monitoring the situation and will restore full functionality as soon as the underlying problems are resolved.
Posted 1 month ago. Jun 12, 2025 - 15:27 EDT
This incident affected: AppOmni APIs.